Not logged in. · Lost password · Register
Forum: General discussion RSS
WinAmp BAD shuffle
Page:  1  2  next 
Avatar
Clay #1
Member since Jan 2003 · 91 posts · Location: Seattle, Washington, USA
Group memberships: Members
Show profile · Link to this post
Perhaps I'm just a pain in the ass but I'm getting real unhappy with WinAmp's shuffle logic ... it seems to play the same tracks way too frequently.<BR><BR>I would like an option to take a track OFF the playlist after it has been played ... any chance?<BR><BR>I love your product! It makes my day!<BR><BR>Clay<BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href=""></a>
Avatar
Saxtus (Administrator) #2
Member since Jan 2003 · 147 posts · Location: Athens, Greece
Group memberships: Administrators, Members
Show profile · Link to this post
I think this was a request in my long request list in a previous thread... <IMG SRC="images/icon_smile.gif"><BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href="http://www.saxtus.gr/">http://www.saxtus.gr/</a>
Saxtus
Avatar
Clay #3
Member since Jan 2003 · 91 posts · Location: Seattle, Washington, USA
Group memberships: Members
Show profile · Link to this post
I thought it sounded like a familiar rant ... it just bugs me that I look at the play log and see the same track repeated so frequently. I think I've also posted this on the WinAmp site with no response.<BR><BR>Thanks for your great skin <IMG SRC="images/icon_smile.gif"><BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href=""></a>
Avatar
Henry (Administrator) #4
Member since Jan 2003 · 865 posts · Location: Munich Germany
Group memberships: Administrators, Members
Show profile · Link to this post
I just implemented the "remove-after-play" feature.<BR><BR>It will be released just when saxtus sets up the new forum... <IMG SRC="images/icon_biggrin.gif"><BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href="http://www.browseamp.com">http://www.browseamp.com</a>
Avatar
Clay #5
Member since Jan 2003 · 91 posts · Location: Seattle, Washington, USA
Group memberships: Members
Show profile · Link to this post
GREAT! THANK YOU!<BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href=""></a>
Avatar
Clay #6
Member since Jan 2003 · 91 posts · Location: Seattle, Washington, USA
Group memberships: Members
Show profile · Link to this post
I've played with this option and I find NO problems!<BR><BR>Thanks for the option to toggle it on/off from the browser.<BR><BR>Good work.<BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href=""></a>
Avatar
Saxtus (Administrator) #7
Member since Jan 2003 · 147 posts · Location: Athens, Greece
Group memberships: Administrators, Members
Show profile · Link to this post
BUG @ 1.77:<BR>Even the administrator can't remove songs that are added directly from WinAMP...<BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href="http://www.saxtus.gr/">http://www.saxtus.gr/</a>
Saxtus
Avatar
Henry (Administrator) #8
Member since Jan 2003 · 865 posts · Location: Munich Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Sorry, my fault! <IMG SRC="images/icon_frown.gif"><BR>Have fixed it and it's ready for download. <BR>I have not changed version number.<BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href="http://www.browseamp.com">http://www.browseamp.com</a>
Avatar
Clay #9
Member since Jan 2003 · 91 posts · Location: Seattle, Washington, USA
Group memberships: Members
Show profile · Link to this post
I think there might be a memory leak. I let the system run overnight with the "remove" feature on. It didn't delete the last track in the playlist and stop, like I expected, and kept playing the last track over and over ... when I looked at the server in the morning it had a message about the need to increase virtual memory.<BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href=""></a>
Avatar
Henry (Administrator) #10
Member since Jan 2003 · 865 posts · Location: Munich Germany
Group memberships: Administrators, Members
Show profile · Link to this post
It's correct that it does not delete the last track because it only deletes the last played song when the song changes. The last track never changes (CRC32) and so it will never be deleted.<BR>Yet I have no idea how to handle that.<BR><BR>Was a page continuously refreshed during that night? If yes, which one?<BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href="http://www.browseamp.com">http://www.browseamp.com</a>
Avatar
Henry (Administrator) #11
Member since Jan 2003 · 865 posts · Location: Munich Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Yes, there is a memory leak! It comes from the CRC32 function. Everytime it is called some memory is not released.<BR><BR>I suppose this is a Borland bug because I cannot see anything wrong in these 10 lines of code... maybe I'm blind ... <IMG SRC="images/icon_cool.gif"><BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href="http://www.browseamp.com">http://www.browseamp.com</a>
Avatar
Clay #12
Member since Jan 2003 · 91 posts · Location: Seattle, Washington, USA
Group memberships: Members
Show profile · Link to this post
OK ... I understand. I was just doing a test.<BR><BR>Perhaps you could detect that the last song is being played and just simulate a "stop".<BR><BR>I'm sure your not blind but in my programming life several times all it took was to explain to another person what you are doing in the code and things just "jump out at you".<BR><BR>Good luck.<BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href=""></a>
Avatar
Clay #13
Member since Jan 2003 · 91 posts · Location: Seattle, Washington, USA
Group memberships: Members
Show profile · Link to this post
One more observation.<BR><BR>I've never had the "short on virtual memory" message before ... even after running for several days. I don't know if that information helps ... just an observation. I know you and Saxtus have talked about a memory leak but I'd never seen it before.<BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href=""></a>
Avatar
Saxtus (Administrator) #14
Member since Jan 2003 · 147 posts · Location: Athens, Greece
Group memberships: Administrators, Members
Show profile · Link to this post
Oh, be sure that there is a memory leak, it very easy for me to understand it after few hours on a P200 with only 64MB RAM <IMG SRC="images/icon_smile.gif"><BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href="http://www.saxtus.gr/">http://www.saxtus.gr/</a>
Saxtus
Avatar
Saxtus (Administrator) #15
Member since Jan 2003 · 147 posts · Location: Athens, Greece
Group memberships: Administrators, Members
Show profile · Link to this post
@Henry:<BR><BR>Can you make entries that is unknown who added them (happens when you add songs from WinAMP directly) to be assigned to a specific user?<BR><BR>Thank you!<BR><BR><a href="mailto:[email protected]">[email protected]</a><BR><a href="http://www.saxtus.gr/">http://www.saxtus.gr/</a>
Saxtus
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Page:  1  2  next 
Go to forum
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Page created in 211.3 ms (115.9 ms) · 109 database queries in 78.8 ms
Current time: 2018-07-17, 09:26:52 (UTC +00:00)