Not logged in. · Lost password · Register
Forum: General discussion RSS
Error #11004 [Cannot convert protocol 'tcp']-Help!
Guest_doslover (Guest) #1
No profile available.
Link to this post
Hey all,

This is my first post, BrowseAmp looks to be a solid project, and a great addition to my SHOUTcast server, however, I cannot seem to start the server.

Any time I try to start the Server on Port 80 (or any other attempted port) it will give the following error:

TitleBar:  gen_brow2
Message:
listen: WSocketResolveProto: Cannot convert protocol 'tcp', Error #11004

Please try another port!

Assuredly, I have tried other ports that I know for a fact are not in use, by using a netstat -a -n.  I am behind a Hardware Linksys Router / Firewall with NAT enabled, but I have attempted not only Port Forwarding, but actually setting up my machine as a DMZ, which doesn't seem to help.  It would appear to be an issue on my machine specifically not wanting to listen on any given port, but I have no software firewalls installed, nor anything else I can think of that would block it.

I am currently running XP Pro with all the latest updates (which could be the problem, heh) the newest version of Winamp (5.03a Full) and the latest version of BrowseAmp (2.08) - Both of which have been completely removed / reinstalled.

I plan to continue poking around, but I'm quickly running out of ideas...  Has anyone else seen this error before?

Thanks in advance,
~James~
Avatar
Henry (Administrator) #2
Member since Jan 2003 · 865 posts · Location: Munich Germany
Group memberships: Administrators, Members
Show profile · Link to this post
I suspect you have a problem with your TCP/IP installation.

Maybe you have been hit by a virus that messes everything up. They change in the registry the location of the "protocol" file which does the translation between protocol names and protocol numbers.

Or maybe you simply have corrupted your protocol file (NT/2K/XP: Windows\System32\drivers\etc\protocol).
It's a text file whithout extension. You can copy it from any other working system.

If the virus changed the location of that file in the registry, you must restore the entry to its correct value. Maybe reinstalling the TCP/IP protocol could help too.

-- thanks to the ICS Mailing List
This post was edited on 2004-05-26, 18:40 by Unknown user.
doslover #3
Member since May 2004 · 2 posts
Group memberships: Members
Show profile · Link to this post
Ahh,  good point, I hadn't thought of that.  I do have AVG 6.0 (updated all of 3 days ago) along with Ad-Aware 6, updated today, so I think I'm good on viruses / malware. 

I'll try running the TCP/IP Reset script, though, and see if that has any positive effect for me.  I'll get back to you after that.

Thanks,
~James~
doslover #4
Member since May 2004 · 2 posts
Group memberships: Members
Show profile · Link to this post
Yep, sho'nuff that did it.   :-D

Just incase anyone in the future comes across this problem and searches to find this thread, the command to run in 2000/XP is:

netsh int ip reset resetlog.txt
(Also good for troubleshooting connectivity issues)

Or for ME and previous, just uninstall/reinstall

Now I'm off to play!

Thanks for the idea Henry!
spuzzdawg #5
Member since Aug 2004 · 1 post
Group memberships: Members
Show profile · Link to this post
Does anyone have any suggestions if that command didn't fix the problem?
Guest_Spuzzdawg (Guest) #6
No profile available.
Link to this post
Doesn't matter - I read over this thread again whilst actually paying attention this time. Fixed it by replacing that protocol file - think it was deleted by a stupid virus.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Page created in 154.8 ms (72.2 ms) · 58 database queries in 58.4 ms
Current time: 2018-07-21, 17:20:40 (UTC +00:00)