Not logged in. · Lost password · Register
Page:  1  2  next 

All posts by SteveB (29)

topic: Checking multiple instances... (...to prevent port binding problems!)  in the forum: General discussion
SteveB #1
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
There's a fairly simple workaround to this. It's not the "cleanest" solution ever, but should work!

Under C:\Program Files, copy your entire Winamp directory to WinampService (or whatever you want to call it). Then you'll have two totally separate installations of Winamp and each is separately configurable.

Configure FireDaemon to run C:\Program Files\WinampService\Winamp.exe (Thanks for the link to FireDaemon by the way - looks useful!)

If you configured the one running as a service to use BrowseAmp, and the other one NOT to use BrowseAmp, it should solve your problem.

In fact, you could have them both running BrowseAmp on different ports if you wanted!

Steve
topic: Easy Album Art  in the forum: Features request
SteveB #2
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
Yes, makes sense. How about making it configurable in the properties screen so you could enable/disable access to files outside the root folder?

Cheers,
Steve
topic: Easy Album Art  in the forum: Features request
SteveB #3
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
WOW! Now that's what I call quick service ;)

Yep, that's fixed it - thanks Henry.

Am I right in thinking it's by design that it doesn't work if the playlist refers to a drive other than the BrowseAmp's root? e.g. if I store my playlists on Q: drive and they list files on M: drive? (Which I do, but I'm sure I can work round that :) )

BTW - "SteveB edition" - my very own edition of BrowseAmp! lol  :-D

Thanks again

Steve
topic: Easy Album Art  in the forum: Features request
SteveB #4
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
Hi. I've finally made the switch the BrowseAmp 2 and it's fantastic - what took me so long?!

I've been playing with this album art stuff, which is great when it works but the trouble (for me) is that it doesn't seem to work all the time.

My MP3s are in folders like "Artist - Album". Each folder contains MP3s, a playlist, and a cover.jpg file. If I load the playlists, the cover art displays fine.

I also have a directory structure containing only playlists sorted by genre that link back to the files above (using the same drive letter) e.g. !playlists\rock\Pink Floyd - The Wall CD1.m3u. If I load one of these playlists the cover art doesn't display.

I had a look at the IMG tag in the page source to see what's wrong. The only difference is that in the tag that works the drive letter is upper case, and in the one that doesn't work it's lower case e.g.

<img src="cover.jpg?src=M:\Dreamland" width="100"> (works)
<img src="cover.jpg?src=m:\Dreamland" width="100"> (doesn't work)

I guess I could use some JavaScript to convert the drive letters to upper case but I'm not really sure that's the right approach. Could this be a bug?

Thanks,
Steve

PS Azimuth - I like your TTunes skin!
topic: Need Help With Search Function...  in the forum: General discussion
SteveB #5
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
Glad to hear it worked!
topic: Need Help With Search Function...  in the forum: General discussion
SteveB #6
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
Aaron,

I've just tried this, and it seems to work:


  <form name="form1" target="playlistframe" method="get" action="playlist2.html" class="standard">
    search:
    <input type="text" name="searchstring">
    <input type="submit" name="button" value="  search  ">
  </form>

  <p class="standard"><a href="#currentsong">jump to current song</a>
  </p>

<iframe name="playlistframe" width="550" height="300" src="playlist2.html"></iframe>


playlist2.html (actually called test_playlist2.html, but you knew that...) just contains a simple playlist tag. Tell you what, I'll zip the files and attach them...

HTH

Steve
The author has attached one file to this post:
testiframe.zip 7.2 kBytes
You have no permission to open this file.
topic: Mime Types  in the forum: General discussion
SteveB #7
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
How about this:

http://hostutopia.com/support/s058.html

Can't vouch for its correctness, but it seems pretty comprehensive.
topic: Playlist Order With .m3u Files (Playlists load in wrong order)  in the forum: General discussion
SteveB #8
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
Thanks Henry. I can understand not wanting to hack the old code. I'd actually be pretty happy to switch to the new Browseamp. Does it have all features implemented yet (and is it stable)? That's all I've really been waiting for. Well, that and I'm too lazy to re-code my skin, but I knew I'd have to do it sooner or later :)

Cheers,
Steve
topic: Control Multiple Winamp Sessions?!  in the forum: Features request
SteveB #9
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
Aaron, I've tried somehting similar to this (not using Browseamp). the problem you get is that the different zones get out of sync with each other. Not a problem if you can only hear 1 zone at a time I suppose but it sounds a horrible mess if you can hear 2 zones that are slightly out of sync. Like a really bad DJ :)
topic: Playlist Order With .m3u Files (Playlists load in wrong order)  in the forum: General discussion
SteveB #10
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
I've just spent ages trawling the Winamp forums (which are now back up), and a lot of people describe problems similar to the one above, but *NOT* the same. Mostly they talk about drag & drop, or using the Windows context menu to play all files in a directory. The key to those problems is that the files are loading in the order they're stored on the disk - either by file date or by the order the FAT lists them in. A few suggested answers talk about the "Sort files on load" option, or sorting manually after loading the files.

None of that helps solve the problem described above though.  :( I suppose if there's no other solution I could re-order all my playlists so the 2nd track is listed last, but that's a huge nasty horrible kludge!

Henry, do you use a different function to load the playlist into Winamp in Browseamp V2? (cos that works fine)? Any chance you could change V1.8x to use the same function?

--Steve
topic: Where Have The Winamp Forums Gone?  in the forum: General discussion
SteveB #11
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
They're back
topic: Simple Touchscreen Skin  in the forum: Skins
SteveB #12
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
Yeah, they're all extinct. The only way to get them is from warehouse clearances, second hand, that kind of thing. I has to import mine across the pond (I'm in the UK). The CF-01 came from Texas - took a month or two, and the Pt510s from Canada - took an astonishing 4 months to arrive!  :blink:

The 510s came from this site:

http://www.positivesale.com/

..although I don't know whether there are any left. Also, be warned that a few people have had problems getting hold of the devices having handed over their money. The guy that runs the site blamed it on the Canadian postal system. Mine did arrive in the end...!

Good luck!
topic: Simple Touchscreen Skin  in the forum: Skins
SteveB #13
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
Tabs? I don't have any tabs! The links across the top just link to different pages...

You could make it look & behave like tabs just by putting different graphics across the top of each page. I don't know if that's how Aaron's done it.
topic: Browse Files Without Extensions  in the forum: Features request
SteveB #14
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
How about an option to list the files in the browser without showing their file extensions?

Also, I'm using quite a few shortcuts, and it can look a bit untidy showing a list of "somefile.m3u.lnk", where "somefile" would do. It's probably more wife friendly that way, too :)

...just a thought
topic: Simple Touchscreen Skin  in the forum: Skins
SteveB #15
Member since Apr 2003 · 29 posts
Group memberships: Members
Show profile · Link to this post
Wow! That looks fantastic! It looks like you're doing some pretty similar things to me. I've got various X10 (and other non-X10) devices all over the place including the aquariums, like you :)

I've also spent quite a while encoding my DVDs to DivX files so I can have them online in a similar jukebox setup. I was using ShowShifter but now that Winamp supports playing video it looks like I might switch to using Winamp for both audio and video. It would certainly make for a less complicated setup. BrowseAmp seems quite happy to handle video files in Winamp too. One of the hurdles I saw in doing this was being able to jump around in the video - so I've just put together a clickable asp progress bar (in another iframe). It works for both video and audio files - see attached pic. I've been toying with the idea of some sort of jog dial, but maybe that would just look messy...

Anyway, looking forward to working with you on some of this stuff  B)
The author has attached one file to this post:
progressbar.jpg 39 kBytes
You have no permission to open this file.
Close Smaller – Larger + Reply to this post:
Special characters:
Page:  1  2  next 
Special queries
Go to forum
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Page created in 224.9 ms (145.1 ms) · 128 database queries in 103.1 ms
Current time: 2019-08-22, 09:16:41 (UTC +00:00)